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[bookmark: _Entering_and_Editing]Entering and Editing Data
In addition to collecting data using Logger Pro, there are other ways to input data. For example, you can type data directly into the data table or import data from text files such as those created in Microsoft® Excel® or Word®.

· To type data directly into a cell, click in the cell and type a value. You can use either the mouse or arrow keys to navigate between and within the table cells. Press the Enter/Return key after you type the value to move to the cell below or to the right. 
1. To import a text file from Microsoft Excel, start Excel and open or create your spreadsheet.
a. Choose Save As from the File menu and choose Text (*.txt) for Save as type.
b. Import the data into Logger Pro by choosing Import From > Text File from the File menu and navigate to the file.
2. To import from a word processor, type rows of data and separate each data point by a tab character. Save this as a text (.txt) file. Import the data into Logger Pro by choosing Import From > Text File from the File menu and navigate to the file.
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[bookmark: _Data_Collection:]
Data Collection
[bookmark: HowtoBegin]How to Begin
1. Connect the LabQuest® Mini or Go!-Link® to the USB port on your computer running Logger Pro. 
2. Connect the sensor(s)/probe(s) to LabQuest Mini or Go! Link.
Note that Logger Pro will automatically detect the sensor(s)/probe(s).
3. To start collecting data, click Collect [image: ]. 
Data will be displayed in the data table and the graph. 
4. You can stop data collection at any time by clicking Stop [image: ]. 
Note that you can also select Start Collection from the Experiment menu.
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[bookmark: StoreMultipleRuns]How to Store Multiple Runs
Starting data collection will overwrite previously collected data (if data were collected in time mode and data collection lasted for less than 60 seconds). To prevent losing your data, you need to store your data after each run.

1. BEFORE you start data collection again, choose Store Latest Run from the Experiment menu. This option saves the most recently collected data and allows you to collect additional data without losing a previous run. 
1. Make sure to always choose Store Latest Run before you collect more data or the run labeled Latest will be overwritten when you collect more data. 
1. Note that choosing Store Latest Run does not save data to a file nor preserve your data between sessions or when you turn off your computer. You must choose Save from the File menu to save your data.
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[bookmark: _Data_Analysis:]Data Analysis
[bookmark: ScaleaGraph]How to Scale a Graph
6. You can autoscale a graph by clicking Autoscale [image: ] on the toolbar or by choosing Autoscale from the Analyze menu. This feature automatically adjusts the graph axes so that all data fits with little empty space.
7. You can manually scale a graph by changing the endpoint value for either axis. There are three ways to do this:
· Click the largest or smallest axis value and edit the value.
· “Stretch” the axis by hovering the cursor over the axis until the cursor turns into a squiggly arrow. Then, click and stretch the axis. 
· Right-click on the graph and select Graph Options. Click the Axes Options tab and enter the values for the endpoints of both the x- and y-axes.

[image: ]
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How to Determine the X- and Y- Data Points on a Graph
When the Examine feature is on, a vertical indicator line appears on the graph and a floating box shows the x- and y-coordinates of the data point. You can position the line by moving the cursor or pressing the left and right arrow keys on the keyboard. The Examine box is updated automatically to reflect the current location of the indicator line. 
1. Turn on the Examine feature by either clicking Examine [image: ] on the toolbar or choosing Examine from the Analyze menu. 
1. Turn off Examine by clicking the Z in the upper corner of the Examine box or choosing Examine from the Analyze menu.
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[bookmark: PerformLinearFit]
How to Perform a Linear Fit
The Linear Fit feature draws a linear regression line over the selected area of a graph and calculates the slope (m) and y-intercept (b) of that line.

1. Click and drag across a region of interest. The shaded area contains the selected data for which to calculate the linear fit. If you do not select a region, the linear fit will be calculated for all data displayed in the graph.
2. Choose Linear Fit from the Analyze menu or click Linear Fit [image: ] on the toolbar. 
A helper object containing the slope, y-intercept, and correlation coefficient of the regression line will be added to the graph. A correlation coefficient is a number between -1 and 1 that measures to what extent two variables are linearly related. A perfect correlation with positive slope is shown by a +1 correlation, while a negative slope is shown by a -1 correction. 0 means that there is no linear relationship.
3. To remove the linear fit, click the X in the upper corner of the helper object.
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[bookmark: IntegrateDataSet]How to Integrate a Data Set
The Integral function calculates the area under a segment of the graph. The selected area is filled on the graph while a helper object displays the numeric result. 
1. Click and drag the mouse across the segment that you want to integrate. The shaded area marks the beginning and end of the range with brackets. If you do not select a range, the curve will be calculated to the entire range of data displayed in the graph.
2. Choose the Integral function by either clicking Integral [image: ] on the toolbar or selecting the Integral option from the Analyze menu.
3. Click and drag the brackets, and the integral updates automatically.
4. To remove the integral from the graph, click the X in the upper corner of the integral helper object.
5. To edit the integral’s properties, double-click the helper object. The Integral Options dialog box opens.
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[bookmark: _Video_Function]Video Functions
[bookmark: CaptureVideo]How to Capture Video
1. Install any drivers or software that came with your camera. Verify that you can see video using the manufacturer’s software. Do not continue until this software is functioning. Once it is functioning, exit that software before you continue.
2. Connect the camera to the computer, if not already connected.
3. Launch Logger Pro.
4. Choose Video Capture from the Insert menu. If a camera is detected, the Video Capture dialog box opens. It displays an active video feed from the camera. If you do not see the live video feed, click the Set Up Camera button and configure your camera. 
5. You are now ready to capture video in one of two modes. One mode is to collect the video by itself. The other mode is to capture a video while simultaneously collecting data with sensors. 
· Video Capture Only 
Note that the Video Capture dialog box shows live video. 
1) Click the Options button in the Video Capture dialog box to choose the Video Capture Only mode. 
2) Set your desired capture duration. 
Note: Long captures that are not time-lapsed create very large files. 
3) To capture video, click Start Capture. You can let the capture run for the allotted time or click Stop Capture. 
4) At the end of the capture, a movie player for the capture appears on the screen. If you capture additional videos, they also appear on the screen. 
5) To save the movie or movies, choose Save from the File menu. Choose the appropriate folder and give your file a name. 
The movie(s) will be saved in the same directory with the Logger Pro file. If you have not changed any Advanced Settings, the video files are named sequentially as MovieCapture1, MovieCapture2, etc. 
· Video Capture While Simultaneously Collecting Data
Note that the Video Capture dialog box shows live video. 
1) Click Options to open the Video Capture Options dialog box. 
2) Choose Video Capture Synchronized with Sensor Data Collection. 
3) If data collection will run more than 10–15 seconds, you may want to capture a time-lapse movie to avoid creating a very large video file. Click the Time Lapse Mode option, and choose how often you want to collect an image. 
4) Click OK. 
Note that when you click Start Capture or Start Time Lapse, video capture and data collection begins. At the end of the capture, a movie object for the capture appears on the screen. 
5) To save the movie or movies, choose Save from the File menu. Choose the appropriate folder and give your file a name. The movie(s) will be saved with your Logger Pro file and in the same directory as the Logger Pro file. If you have not changed any Advanced Settings, the video files will be named sequentially as MovieCapture1, MovieCapture2, etc. 
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[bookmark: SyncMoviestoExperiment]How to Sync Movies of Your Experiment to Your Data
You can insert video recordings of your experiment into the experiment files. You can then synchronize the video to your data so that when the experiment is replayed, you can view the data and video together.

1. Choose Movie from the Insert menu, and select the movie you want to add to your page. Supported movie formats are: Video clip (.avi), QuickTime movies (.mov), or any movie format that QuickTime can support. 
2. Find a spot in the data that is easy to identify in the movie; for example, the point at which a ball reaches the peak of a toss. You can do this two ways: 
· Move the mouse cursor over the graph and examine the mouse coordinates in the lower left corner of the screen (as long as Mouse Position and Delta is checked in the Graph Options dialog box). 
· Use the Examine feature [image: ] and scroll the mouse across the graph. This method will give you a time more precisely aligned with the data. 
3. Click the Sync button [image: ] to open the Movie Synchronization dialog box. 
4. Enter the time or click on the graph at the point that you identified earlier as the Graph Time. Make sure you choose the correct Data Set. 
5. Use the slider and the Next Frame/Previous Frame buttons to find the frame in the movie that corresponds with the data point you identified in the graph. Click OK. 
6. Choose Replay from the Analyze menu to view the synchronized movie and data. 
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[bookmark: AnalyzeVideo]How to Analyze a Video
Before you can analyze a video, you must add a movie to your experiment file as described in the previous section. Choose Movie from the Insert menu, and select the movie you want to add to your page. Supported movie formats are: Video clip (.avi), QuickTime movies (.mov), or any movie that can be played by QuickTime. 
1. In the movie player box?, click [image: ]. 
The video analysis tools appear on the right side of the movie player. A graph is also displayed. By default, the graph displays both the x and y positions versus time. 
2. If necessary, resize and move the graph to a desired position. 
3. Set a scale for the analysis. For this, it is important to have something in the movie to set the distance by. You could include a meter stick in the movie to function as a reference. 
a. Click [image: ]. Then click and drag the mouse from one end of the reference to the other end. 
b. In the dialog box that opens, enter the Distance and the appropriate Unit for the object you are using. For example, for a meter stick, enter 1 as the Distance and m for Units. 
4. Click [image: ]. 
5. In the movie player box?, click the Play button, and just before the object in the movie begins its motion, click the Stop button. 
6. Click the Next Frame button and advance the movie until the object is in motion. 
7. Move the mouse over the movie and use the crosshairs to locate a recognizable point on the object. 
8. Click the mouse. A mark is left on the screen and the movie advances one frame. 
9. Repeat until you have marked the point you want to analyze. 
10. Click the Play button to see the object move and to display the record of its horizontal and vertical position on the graph. Use Logger Pro's various analysis features (including Curve Fits) to study the object's motion. 
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[bookmark: _Menu_Options:]Menu Options
[bookmark: ExperimentMenu]Experiment Menu
The Experiment menu contains options that control the collection and storing of data.

	Start Collection
	Start data collection.

	Store Latest Run
	Save the most recently collected data in memory, so you can collect another data set without losing the first.

	Clear Latest Run
	Delete the data from the most recently collected data run.

	Keep
	Store one data point at a time in the Events with Entry and Selected Events data-collection modes.

	Extend Collection
	Increase the length of the data-collection period by 50%.

	Connect Interface
	Confirm or change the interfaces detected by Logger Pro.

	Remove Interface
	Remove any or all interfaces from Logger Pro.

	Set Up Sensors
	Manually set up Logger Pro for a particular sensor.

	Add Offline Interface
	Design experiments and save files even when you do not have the interfaces or sensors plugged in.

	Data Collection
	Modify data collection settings for your experiment, including data-collection mode and sampling rate.

	Remote
	Prepare a device for data collection away from the computer.

	Change Units
	Change the units of measurement for sensors, such as a motion detector or temperature probe.

	Calibrate
	Calibrate the sensor(s) connected to the interface or computer.

	Zero
	Reset the reported value of a sensor, such as a Force Probe, to 0 without otherwise changing the calibration.
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	[bookmark: DataMenu]Data Menu
The Data menu contains functions for clearing and storing your data. It also contains options to edit certain features of the columns in the data table, add new columns to the data table, and edit definitions of user-defined columns.
New Data Set: Create a new data set.
Show Data Set: Show a hidden data set.
Hide Data Set: Hide a data set in all objects that are displayed.
Data Set Options: Name or add comments to the data set.
Sort Data Set: Choose whether the data are sorted in ascending or descending order.
Delete Data Set: Delete individual data sets.
New Manual Column: Add a column of data manually.
New Calculated Column: Create a new column involving calculations.
User Parameters: Adjust parameters or values in calculated columns.
Column Options: Edit an individual column.
Delete Column: Delete individual columns.
Clear All Data: Clear all the data in the file.
Back to Top
	


[bookmark: AnalyzeMenu]Analyze Menu
The Analyze menu contains functions for examining and analyzing your data. Note that a tutorial covering various analysis features is available. To access the tutorial, choose Open from the File menu, then open the Experiments folder.

Replay: Replay data collection at a selected rate.
Replay Latest: Replay latest data collection.
Examine: Show the x- and y-values of the data point closest to the mouse pointer.
Interpolate: Calculate the y-axis value along a curve fitted to the data for any x-axis value.
Tangent: Show the slope of the tangent line at the point closest to the mouse pointer.
Integral: Calculate the area under a segment of the curve.
Peak Integration: Calculate the area in a peak. Useful for analyzing gas chromatograms.
Statistics: Calculate the minimum, maximum, mean, and standard deviation of the selected data.
Linear Fit: Fit a straight line and calculate the slope and y-intercept to the selected area of a graph.
Curve Fit: Fit a user-defined function over the data.
Model: Perform a manual curve fit of your data
Interpolation Calculator: Choose a curve fit, and the calculator will interpolate the x-value.
Legend: Display the name and point protector for each data set.
Zoom Graph In: Zoom in 50%, or zoom to a selected area within a graph.
Zoom Graph Out: Undo previous zoom, or zoom out to twice the range.
Autoscale: Scale the ranges of selected graph(s) to the extreme of visible traces.
Draw Prediction: Manually draw a prediction of data on a graph object.
Graph Match: Automatically generate a graph match.
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[bookmark: Tutorials][bookmark: _GoBack]Tutorials
A variety of tutorials are built into Logger Pro. These tutorials are available in the folder titled Tutorials, which you can access through File > Open. The following tutorials are available:
01 Getting Started – This tutorial gives an overview of the Logger Pro software.
02 Temperature Measurement – This tutorial shows how to make simple measurements using a Temperature Probe and Logger Pro. You will learn to perform some basic analysis of those data.
03 Events with Entry – This tutorial teaches you how to perform an experiment that uses the Events with Entry data collection mode. This mode is different from the time-based data collection mode. In Events with Entry, Logger Pro records a measurement with the sensor and the user enters a value that is related to that measurement.
04 Motion Measurement – This tutorial leads you through the use of a Motion Detector with Logger Pro.
05 Manual Data Entry – An important feature of Logger Pro is the ability to manually enter data, graph the data, and analyze it. This tutorial guides you through some of the basic features of manually entering data into Logger Pro.
06 Customization – This tutorial shows you how to customize a file so that it looks pleasing to your eye.
07 Viewing Graphs – This tutorial shows you some of the features that make viewing a graph easier. It teaches you how to rescale the axes, stretch the axes, zoom, autoscale, and scroll.  
08 Stats, Tangents, Integral – In this tutorial you will investigate the statistics, tangent, and integral features of the program. You will also create and graph a calculated column using the derivative.
09 Curve Fitting – This tutorial guides you through the various aspects of both automatic and manual curve fits. You will also learn to define your own function and use modeling to arrive at an appropriate equation for a set of data.
10-1 Linearization – An important feature of Logger Pro is the ability to quickly graph data and find the relationship between variables. One option in finding these relationships is to perform a curve fit. The other option is to "linearize" the data. This method of analysis is performed with columns of modified data. This concept is based on the idea that if a graph produces data along a straight line, then the relationship displayed to the right is true.  
10-2 Linearization – This is an exercise in linearization of data. It is a supplement to tutorial "10-1 Linearization."   
10-3 Linearization – This is an exercise in linearization of data. It is a supplement to tutorial "10-2 Linearization."   
11-1 Working with Movies – Logger Pro can import videos of your experiment. You can then synchronize the video to your data so that when the experiment is replayed, the data and video can be viewed together. This can be a powerful learning tool. 
In this tutorial and the next, you learn how to: insert a video into an experiment file, use two different methods to synchronize video to data, and use the replay feature to analyze the experiment.
11-2 Working with Movies – In the previous tutorial you were able to synchronize the data and movie by understanding the relationship between a frame in the movie and a corresponding point on the graph. However, sometimes it may be difficult to recognize this relationship. The difficulty in this process lies in the fact that when you start the data collection, it can be difficult to know exactly when the collection started. This tutorial teaches you the ways around this problem and leads you toward another way to synchronize the data and movie. 
12 Video Analysis – This tutorial introduces you to the video analysis feature of Logger Pro. The feature is used to graphically analyze motion recorded in movies or video files. In this tutorial you learn how to: open the video analysis feature, set up graphs for analysis, analyze a video, and perform further analysis of the data.
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